Jump to content

If you encounter an error while browsing ArcheAgeSource, please report it in the Website Feedback forum!
Welcome to ArcheAge Source
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
Photo

Can't log on ArcheAge website nor Glyph . . .


This topic has been archived. This means that you cannot reply to this topic.
No replies to this topic

#1
Hoaz

Hoaz

    Community Newbie

  • Members
  • Pip

The other day I ran into the issue with Archeage, I had entered the password wrong too many times, as such, they blocked me from their site. As their support site requires you to log in to actually do anything useful, I was at a lost and did not know what to do. I began my search for a solution and I tried most things.

   All devices on the network has been blocked, as It only says "Establishing secure connection..." and then directs me to the "Webpage not available" page. 

   I sent in a mail to their support, but three days have passed and I have yet to receive any help. The only thing I have received was "your ticket has been submitted" :/

 

  I'm at a lost, can anyone help me solve this? :)

 

  Thank you in advance!

 

 

Sincerely, Hoaz.